Posted on

Hybrid Core 5.0 Offers a More Modern, Modular Approach to WordPress Theme Development

image credit: Shopify

Version 5.0 of Hybrid Core, one of the longest-running WordPress theme frameworks, is now available. Justin Tadlock celebrated 10 years with his Theme Hybrid community last month and released his new Mythic starter theme into beta. Mythic was built on top of Hybrid Core and developed in tandem with version 5.0.

The framework has been rewritten almost entirely from scratch to be a leaner, more modern starting place for theme development. Tadlock describes it as “a fundamentally different framework, rewritten from the ground up, that supports more modern PHP practices.”

“I started 5.0 with a goal of bringing the framework up to date with more modern PHP practices and code,” he said. “The first iteration of the framework was built in 2008, so it was time to get us ready for the next era of theme building.”

In nearly a decade of supporting the framework, Tadlock found that users didn’t always know how to get started building something from scratch. Many copied one of his existing themes and would add and remove things from it based on their own needs.

Version 5.0 doesn’t necessarily make it easier to build on top of Hybrid Core with its new, more complicated method of bootstrapping, new view system for templating, and requirement for using Composer. This is why Tadlock is officially recommending Mythic as the path for building a theme with Hybrid Core in the future. Most of the documentation and tutorials he plans to create in the future will be centered around the Mythic starter theme, which is nearing a 1.0 release.

For many theme developers, Mythic’s use of the BEM (Block-Element-Modifier) CSS class-naming system is their first introduction to a system of non-hierarchal, component-based CSS. Because BEM doesn’t rely on nested selectors, it’s easier for users to overwrite CSS that they want to change. Tadlock explains the benefit for child themes in a recent post about why Mythic uses BEM.

A handful of the Hybrid add-ons are now available as Composer packages, including one for breadcrumbs, customizer controls and settings, Google fonts, and a featured image script. Tadlock plans to split more parts of the framework off into packages in the future for an increasingly modular core.

Hybrid Core 5.0 requires PHP 5.6+ (with 7.0+ recommended) and WordPress 4.9.6+. Tadlock will support Hybrid Core’s 4.x series for at least another year to give theme authors time to adapt.